Forum Update: Language Translation is LIVE!

Bonjour, Hola, Zdravstvuyte, Nǐn hǎo, Salve, Konnichiwa, Guten Tag, Hello,


After all this time, the NEAR Governance Forum now has translation features integrated :tada:

The NEAR Community is global, and our forum should be as accessible as possible.

How Do I Use It?!

If you’re browsing a forum thread in a language that is not native to your own, you should be prompted to translate this at any time using this button at the bottom of any reply/thread:


Note: If you’re using a VPN, it may not work as intended.

Please let me know if you’re having any trouble with this, the feedback is appreciated!

Thank you :muscle:


Hey, @David_NEAR

I think he will be grateful to those who need him. I think it’s a great progress, thanks to you. From saying to doing! Wonderful, with ES → EN it works fine.

I have tried it!, but it is not allowing me to translate EN → ES. Sometimes I have wanted to try and the button does not appear when the original text of the post is in English.

And I wanted to be sure that I understand what it says :100:

Are you using a VPN by any chance?

Hi, My internet is not going through a VPN, I have already checked, neither activated locally, nor provided by my ISP.

Let’s look at the following example, which could be seen as the language they speak on Cybertron. Check it

There the gray button does appear, but it does not translate EN → ES.

I have not been able to see the translation to ES of any post in EN, since the button is not activated, and I think that this is a barrier for the onboarding of Spanish speakers.

Another example where I tried. Here, any of those languages can be translated to EN without problem, because the button appears and allows it. But I can’t translate any of them into Spanish.

To help you, I have sent a message through NEAR Venezuela (Discord), so that other members of the Community can try and verify if the button appears and it works, because until now you have not had any feedback, except mine. Gladly to try the translation tool.

All the best

1 Like

Thanks for the feedback, will check it out ASAP.

Got some feedback from the :superhero: devs - this plugin operates using your browser’s language. Is yours set to English by any chance?

With Mozilla Firefox using that example, I did two more tests:

  1. I already had the browser language set to “Español - España” (as default). I removed the alternative, “Ingles - Estados Unidos”, leaving it entirely in Spanish. Restart the browser, and still the operating system (OS). The button does not appear for texts in English.

  2. I went deeper with Regional Configuration (aka locales). I had it set to ES_VE UTF8. I changed it to ES_ES UTF8. Restart, and the situation that I have already reported persists.

There is no proxy server, no VPN. My latest speculation is that it may be something internal to the OS, which in my case is Debian GNU/Linux 11.

Another interesting observation with the same example, but testing the button for reply#4 and #5. The button works fine for #5, Hindi → EN, but for #4, it doesn’t do the translation, the result is the same original text, is supposed to be Hindi as well.

I’m sorry I can’t bring you good news. This only happens to me? I look forward to more feedback from other community members.

David, I have not given up on solving this issue. Therefore, I have tried the following:

  1. Due to the alliance between NEAR and Opera, I have installed the Opera browser on my OS and made adjustments to keep my locale correct, without VPN. And using the same example, the button suffers from the same behavior that I have already reported. Nothing to translate any text into Spanish is possible.

  2. I did a search on the internet and found that this issue is a very common occurrence, not necessarily on the user side, but also because of a deficiency in the API configuration on the server side where the NEAR forum (aka Discourse) runs. I would like to review/discard this explanation …

OK, this is what we’re going to do. Put me in contact with the Devs, to discuss this directly with them, to find a solution and not overload you with tasks. The best thing is that they contact me via DM (in private). I hope we can do this.

Thanks to you


Appreciate the offer, but it’s all good. I’m going to do some digging as I’m able to replicate this on my side, appreciate it!

1 Like


Made progress on this, can you let me know what your interface language is if you head to:

1 Like

YES! :tada:

@David_NEAR excellent, completely solved it, also you are from the Avengers !!! :rocket:

In my earlier browsing of the Discourse help pages, I had seen “Interface Language” under Preferences in a Video, but it wasn’t visible on my profile and I thought it didn’t exist anymore. With the change that have adjusted on the server side now if it appears, and no selected language was displayed. But, adjusting it to “Spanish” and refreshing, now the button works, and it does for some text to Spanish. Surely now it works fine for languages other than English.

This is the help page that I had reviewed and may be useful to others, to be more visual (incl. a Spanish version in the header):

That setting also puts all interface labels in the native language.

Thank you very much, let’s have a party !!!


Awesome work @David_NEAR!

This has been a long time coming. It’s great to finally have this feature live!

I suggest that this post be made under other tags that can make it more visible and accessible to everyone.

If possible, in fact, it should be pinned right at the doorposts of the NGF (in a manner of speaking).

Great work!


celebrate hell yeah GIF by Brooklyn Nine-Nine